首页 > Linux Usage > My Ubuntu installed packages list

My Ubuntu installed packages list

2012-10-29 10:03 星期一    浏览: 1,796    绿 发表评论 阅读评论

退回Ubuntu10.04,重建系统环境,安装软件包,清单记录如下,以作备忘:

(1) Development

vi编辑器及脚本: sudo apt-get install vim vim-gnome vim-scripts  ctags

代码比较工具kompare或meld:sudo apt-get install kompare meld

绘图工具dia、UML图工具umbrello、文档生成工具doxygen和windows程序运行环境wine:sudo apt-get install dia umbrello doxygen wine

版本管理工具git:sudo apt-get install git-core gnupg gitk git-gui

更新git至新版本(避免在使用repo sync下载Android代码时出现错误“error: Exited sync due to gc errors”):

sudo add-apt-repository ppa:git-core/ppa
sudo apt-get update
sudo apt-get install git

开发类库(主要针对android):sudo apt-get install flex bison gperf libsdl-dev libesd0-dev libwxgtk2.6-dev build-essential zip curl libncurses5-dev libusb-dev

64bit Ubuntu: sudo apt-get install git-core gnupg flex bison gperf build-essential zip curl zlib1g-dev libc6-dev lib32ncurses5-dev zlib1g-dev libc6-dev lib32ncurses5-dev ia32-libs x11proto-core-dev libx11-dev lib32readline5-dev lib32z-dev libgl1-mesa-dev g++-multilib mingw32 tofrodos python-markdown libxml2-utils xsltproc (refer to: http://source.android.com/source/initializing.html)

Java开发环境:install oracle-java-jdk  manually (see http://blog.redwolf-soft.com/?p=1796)

代码阅读工具SourceInsight(install SourceInsight manually): wine SourceInsight.exe

(2) Server

http、ftp和数据库服务器:sudo apt-get install  apache2 php5 libapache2-mod-php5 vsftpd   mysql-server

Ubuntu10.04.4中先卸载php5-common(因版本不匹配)然后再重新安装php其它特性支持:sudo apt-get autoremove php5-common,然后再安装:sudo apt-get install php5 php5-common php5-mysql  php5-gd php5-imap php5-ldap php5-odbc php5-xmlrpc php5-curl

mysql客户端和Samba等工具:sudo ap-get install mysql-client samba system-config-samba smbfs

(3) Internet

ftp客户端工具filezilla、命令行网页浏览器lynx和IM工具pidgin:sudo apt-get install filezilla lynx pidgin

代理工具:sudo apt-get install connect-proxy

Chome浏览器:Download Google Chrome and install it manually(https://www.google.com/intl/en/chrome/browser/)

下载skype Linux版:http://skype.tom.com/download/linux.html

sudo apt-get install libqt4-webkit (skype依赖库)

sudo dpkg -i skype-ubuntu-lucid_4.2.0.11-1_i386.deb

(4) Tools

密码管理工具keepassx:sudo apt-get install  keepassx

输入法pinyin或scim输入法:sudo apt-get install  ibus-pinyin          scim scim-chinese

mtp设备支持:sudo apt-get install mtp-tools mtpfs

蓝牙传文件工具obextool和bluetooth manager:sudo apt-get install obextool blueman

Wifi 工具(系统自带的总不能实时刷新)sudo apt-get install wifi-radar

字典:sudo apt-get install stardict

压缩解压缩:sudo apt-get install p7zip-full(或p7zip)unrar-free

思维导图工具:sudo apt-get install freemind

记账工具:sudo apt-get install gnucash

图形化的MySQL 数据库查询器(可选):sudo apt-get install mysql-query-browser(它将自动安装数据库图形管理器mysql-admin)

(5)Images

图形图像:sudo apt-get install imagemagick ksnapshot gimp

(6)Multimedia

ffmpeg及其GUI工具:sudo apt-get install ffmpeg winff

gstreamer解码器:sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-plugin-*

 

(7)其它

安装ssh

若安装openssh-server时提示下面错误:

bill@ubuntu:~$ sudo apt-get install openssh-server
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openssh-server: Depends: openssh-client (= 1:5.3p1-3ubuntu3) but 1:5.3p1-3ubuntu7 is to be installed
E: Broken packages

则需卸载掉默认安装的openssh-client(因版本较新,而openssh-server依赖的版本较旧):

sudo apt-get  autoremove  openssh-client

然后再重新安装它们:

sudo apt-get install openssh-client openssh-server

启动sshd服务:

sudo /etc/init.d/ssh start

这样,可以在远程Linux机器上利用scp命令 往我的ubuntu上copy文件了

 

注:若不记得清晰的名字,可用搜索来查找准确的安装包名称。如,查询php curl支持情况:

apt-cache search curl | grep php

 

 

本文链接地址: http://blog.redwolf-soft.com/?p=1804

原创文章,版权©红狼博客所有, 转载随意,但请注明出处。

    分享到:

相关文章:

  • 无相关文章
  1. 本文目前尚无任何评论.
订阅评论
  欢迎参与讨论,请在这里发表您的看法、交流您的观点。